A warning on older Mac apps

If you’re getting all of the automatic updates to your Mac, you should be on version 10.13.4 right now.   If you’ve been a Mac user for any length of time, you may start to get pop up messages saying that the app you are trying to open is not optimized for your Mac.   Don’t worry, you can still open and use that app — FOR NOW.

Macs have featured 64 bit processors for years.  Your mac OS software is also 64 bit.  However apps designed to the old 32 bit standard have been allowed to exist until the present time.  In the very near future, 32 bit apps will be blocked.   I don’t know all of the software that each of you have installed on your Macs, but it is possible that you have some of the old apps.   Two that I know for sure are Office 2008 for Mac and Office 2011.  The solution to that problem is easy — upgrade to Office 2016. 

If and when you are prevented from using 32 bit apps on your Mac, you will have 2 choices.

1) See if if you can live without the app

2) Upgrade to a more modern version of the app

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s